Stack Exchange network consists of 183 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.
and have whoever else reads our code have to mouse over to understand what it does. But not everyone who works with us uses the same IDE, and people reading the code from the online repository will not even have mouse over...
Not only does this kid need lines of comments to explain each step my code takes, which is understandable, if I forget to comment a very simple loop adding elements to a list, he will take time to comment it. The main point of our argument yesterday was that instead of having verbose method names we should have short ones and rely on function headers to tell people on mouse over to tell people what the function does... We are writing code to click buttons on a relay, and parallel vs serial clicking does different things. He is claiming we should change click_all_simultaneous to just click_all
To my knowledge we do not have a style guide, at least not one that has been shown to me. That would make life a lot easier. And yes, being told my variable names are too specific was a first for me, and it has been rather annoying having him go through and 'refactor' my code as much as he works on writing his own, just so that my variables conform to the standards he learned in his intro to python class...
Unfortunately, we are in the QA department and working in Python, while the rest of the company is in a C-based language. We don't have official coding standards to go off of, just the Python pep-8 guidelines, which are themselves rather vague on the verbosity of method names.